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Introduction 
The NVIDIA Gelato Image Viewer, or "iv" for short, is a tool for displaying 2D images. 
iv can display a wide variety of image formats, including 16-bit and floating point 
formats and can display either single or multiple images. iv can be used to perform a 
variety of functions, including: 

•  Viewing 2D images 
•  Image sequence playback 
•  Comparing and contrasting different versions of an image (looking for minute 

differences between different renders) 
•  Controlling the progress of a Gelato render that is underway 

While iv was created to be used in conjunction with the Gelato final-frame renderer, the 
tool is independent of Gelato and can be used in conjunction with other products or as a 
stand-alone tool. While it is packaged with Gelato, the renderer does not require use of iv, 
and other image viewing tools can be substituted, such as the Maya Render View using 
the Mango plugin. 

Installation & Licensing 

iv is contained in the Gelato software package and is automatically installed and 
uninstalled with Gelato. The Gelato software end user license agreement covers iv and all 
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terms of that license apply to the tool. At present iv cannot be installed or uninstalled 
separately from the renderer. In other words, you must have Gelato installed on your 
machine to use iv. 

iv is not, however, restricted by the Gelato license key. While the license agreement 
governs the legal use of iv, you do not need a license key from NVIDIA to use iv. 

Supported Image Formats 

iv supports any image format for which there is an installed Gelato image I/O plug-in. 
You can extend this functionality by creating plug-ins for new image formats (see the 
Gelato Technical Reference for details). 

iv and Gelato currently ship with the following image I/O plug-ins: 

•  TIFF 
•  JPG 

•  IFF 
•  HDR 

•  PPM
•  DDS

•  OpenEXR

In addition to the above, Gelato ships with a DevIL image I/O plug-in that supports: 

•  BMP 
•  PNG 

•  SGI 
•  TGA 
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Starting iv 
There are several ways to launch iv: 

•  To view the progress of a live render, iv can be launched from the Gelato 
command line using the -iv parameter: 

"%GELATOHOME%"\bin\gelato -iv foo.pyg foo1.pyg Windows 

$GELATOHOME/bin/gelato -iv foo.pyg foo1.pyg Linux 

•  Renders launched with this parameter will open iv and display the in-progress 
render. iv will remain open once the render is complete. Renders that do not use 
the -iv parameter will render to file with no display unless manually specified via 
an Output statement in the input scene file.  

•  Existing image files can be opened from the command line with the syntax: 

iv foo.tif 

•  Multiple images can be loaded from the command line at one time by simply 
listing them in sequence:  

iv foo1.tif foo2.tif foo3.tif 

•  Existing image files can also be opened using the file/open command in the iv 
menu structure.  

•  By launching the iv executable file, iv.exe (Windows) or iv.sh (Linux), either by 
typing iv on the command line or double clicking on the file. This will launch an 
instance of iv with no open images. 

•  By associating a particular file type (e.g., *.jpg) with iv, you can launch iv 
whenever that file type is opened. The Gelato installation does not associate any 
file types with iv; you must do this manually if you wish iv to be the default 
viewer for particular file formats. 

You may have multiple instances of iv open at any given time and multiple images open 
within each instance. There is no arbitrary limit on the number of iv instances or images 
you may have open at any given time. You are only limited by system resources. 
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The iv Window 
The iv window consists of five major 
components. The Title Bar lists the 
name of the active image and, if it was 
rendered by Gelato into the iv 
window, the time the image was 
created. The Menu Bar has five menu 
options, File, Edit, View, Tools, Help. 
The Button Bar contains several 
buttons for controlling the display of 
the image and a drop-down menu 
listing recently opened images. The 
Image Pane displays the active 
image. And finally, the Information 
Bar at the bottom gives metadata 
about the image and access to the 
Gelato error log. 

Button Bar 
The button bar has a number of different tools for viewing images and controlling live 
renders. These can functions can also be found under the View and Tools menus. Some of 
the button bar options govern the behavior of the mouse buttons in iv. 

    Zoom 

The most basic tool is Zoom. When iv opens, the zoom tool is already selected. If you 
have selected another tool, you can re-select zoom by hitting the zoom button on the 
button bar or the zoom radio button in the Tools menu. If you are using any other tool, 
holding down Alt will temporarily switch to the zoom tool. Zoom is controlled by the 
mouse: left click to zoom in; right click to zoom out. Zooming is done in by powers of 2, 
ranging from 1:16 (-4) to 16:1 (+4). If the zoom is at any setting other than 1:1 (0), the 
current zoom setting is shown on the information bar at the bottom of the iv window. 

Mode Zoom in Zoom out 

    Zoom tool Left mouse button Right mouse button 

Alt + Left mouse button Right mouse button 

Ctrl + Mouse 
wheel 

scroll up scroll down 

Hotkey Plus (+) Minus (-) 
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  Select 

The Select tool can be chosen either via button bar or the Tools menu. Select allows you 
to deliniate a rectangular section of the image for various purposes. You do this with the 
left mouse button (click to select a point, drag to select a region). Once a region is 
selected, you can modify it by left clicking on any one of the corners and dragging. Left 
clicking anywhere else in the image pane will remove the box. 

Mode Select 

    Select tool Left mouse button 

Shift + Left mouse button 

  Pan 

The Pan tool, accessed via either the button bar or the Tools menu, allows you to move 
the image in the image pane when only a portion of the image is visible. If the entire 
image is visible in the image pane, Pan does nothing. If only a portion is visible, left click 
and drag the mouse to move the image in the pane.  

Mode Pan 

    Pan tool Left mouse button 

  Middle mouse button 

    Wipe 

The Wipe tool, accessed via either the 
button bar or the Tools menu, allows 
you to split the image pane between 
two different images. It is only active 
if two or more images of the same size 
are loaded. You can select the Wipe 
tool via the button bar or the Tools 
menu. Once selected left click on the 
image and a dividing line will appear 
at that point with the current image on 
the left-hand side of the image pane 
and the previous image viewed on the 
right. The dividing line can be moved 
by left-clicking on it and dragging, 
"wiping" one image with the other. 
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Selecting another open image from the drop down menu or opening a new image will 
load the new image in its entirety. Subsequent clicking on the image pane will again split 
the pane. To remove the split pane switch to another image or manually reload (hotkey = 
enter). 

Mode Wipe 

    Wipe tool Left mouse button 

Ctrl + Left mouse button 

    Full Color/Alpha 

The Full Color and Alpha buttons toggle between a display of the red, green, Blue, 
Alpha, and luminance channels or the alpha channel only. The controls can also be 
accessed via the View menu or the hotkeys, c, r, g, b, a, and l, respectively. Selecting Full 
Color button, from the menu, or with the c hotkey will return you to the normal display. 

For volume shadow maps and images with more than four channels, only one channel is 
displayed at a time. The Previous Channel and Next Channel controls in the View menu 
will change which channel is displayed. The hotkeys are comma and period. Also, the 
Red, Green, Blue, and Alpha commands will jump directly to channels 0, 1, 2, and 3, 
respectively.  

  Store Image 

This button makes a copy of the image and stores it in RAM, accessible via the iv drop-
down menu of images. During normal image viewing and Gelato renders, this button is 
usually unneeded, simply making a copy of what is in the image pane at the moment the 
button is pressed. The button becomes important during Sorbetto re-renders. Normally, 
only one copy of the Sorbetto image, the latest, is retained by iv. Remember that these 
images are only stored in RAM and will be deleted if iv is closed without saving them. 

  Kill Render 

This button kills the active Gelato process. 



Gelato Image Viewer (iv) User’s Guide  June 23, 2006 

 7 

Special Functions 

Pixel View 

The Pixel View window can be used to examine individual pixels 
at high magnification. When the Pixel View window is opened via 
the Tools menu or p hotkey, it displays the pixel under the mouse 
and the surrounding 80 pixels. The window also displays the X-Y 
coordinates of the pixel under the mouse and its RGBA color 
information. The Freeze Closeup command, hotkey x, will hold 
the Pixel View at the current pixel, allowing you to move the 
mouse without changing the Pixel View. This is particularly useful 
if you need to copy the pixel information into another window. You 
can Unfreeze the Pixel View by again hitting x or via the View 
menu. The Pixel View window remains in true, full-color mode at 
all times, regardless of what is being displayed in the image pane. 

Comparing & Contrasting Images 

iv is particularly useful when contrasting two or more similar images, looking for minute 
differences between them. The Wipe and Toggle tools are particularly useful for this. iv 
also allows you to apply random colors to the pixels via the View menu or hotkey shift-R. 
When used in conjunction with the Wipe or Toggle tools, the random colors make it 
easier to identify which pixels have changed. You can then revert back to full color to 
determine the nature of the change, or use the Pixel View window, which always remains 
in true, full-color mode, on the pixel in question. The subtract option (hotkey s) will 
subtract the previous image from the current and display the absolute value of the 
difference for each pixel. Subtract can also be combined with wiping and random colors 
to highlight differences. 

Flipbook Mode 

Flipbook mode allows you to view an animation sequence or to present or demo a series 
of images in sequence. The Flipbook can also be launched from the command line or 
from a script; see the section on Command Line Options for details. 

The speed of the flipbook playback can be varied from many seconds per frame (values 
between zero and 1) up to full speed, which varies depending on image size and system 
performance. Playback speed and direction can be modified via the Tools menu or on the 
command line. 

The arrow keys can be used to play forward or backwards (right and left arrow) or to 
speed up or slow down the playback speed (up and down arrow). Hitting any arrow key 
during playback will stop playback. 
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Sequences can loop using either standard looping (ABCDABCD) with a pause at the end 
of the sequence, or ping-ponged (ABCDCBABCD) without any pause. 

Controlling Live Renders 

iv can be used to interactively control 
live Gelato renders. This Interactive 
mode is enabled whenever a Gelato 
render is launched with the -iv 
parameter, which instructs Gelato to 
send the completed tiles to iv as they 
are rendered. Alternatively, you can 
use the Output statement to specify iv 
as the destination of a render in the 
Gelato scene files. 

If an instance of iv is open when a 
new render is started, the render 
process will create an new image in 
the current iv and send rendered 
buckets to that image. If you launch multiple renders at the same time, they will all be 
sent to iv and you can view their progress by toggling or using the drop-down image 
menu. If you wish to force the render to start a new instance of iv, you must first 
disconnect the current instance, using Ctrl + d or the command in the Tools menu. 

You can instruct Gelato to render a particular part of the image first. Use the Select tool 
(or simply shift-left-click) to select a pixel, and Gelato will render that bucket next and 
then proceed to render adjacent buckets in an expanding outward spiral. You can also use 
the Select tool (or simply shift-left-drag) to draw a rectangle and Gelato will render the 
contents of the rectangle first. (These require that Prioritize Selection is active in the Edit 
menu, which it is by default.) 

You can kill an in-progress render with the Kill Render button on the Button Bar, with 
Ctrl + k, or by the command in the Tools menu. 

You can display multiple outputs from a single Gelato render on different iv pages. By 
default, iv will only display the first Output statement (or RGBA if no Output statement 
exists) in the input scene files. By adding "-data all" to the gelato command line, Gelato 
will send each Output statement to iv as a separate page. 
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Menu Options & Hotkeys 

File Menu 

Control Hotkey Functional Description 

Open Ctrl + o Opens a new image from a file 

Open 
Next 

Shift + Ctrl 
+ o 

Opens the next file of the same type, in filename order, 
in the directory. 

Close Ctrl + w Closes the active image. Note that if you turn off the 
"Ask before closing unsaved images" preference, the 
image will not be saved before closing. If the 
preference is on, you will be prompted to save modified 
images before closing. 

Save As Ctrl + s Saves the active image to file 

Save 
Window 
As 

Shift + Ctrl 
+ s 

Saves exactly what is displayed in the iv image pane 
and not the entire image. If the image is zoomed, it only 
saves the visible portion. If random or false colors are 
applied, it saves these. It also saves anything else you 
see in the image pane, including icons, cursors, the 
wipe bar, etc. 

Save 
Selection 
As 

  Saves the portion of the image that is bounded by the 
Select Tool 

Reload Enter Reload the current image if it has changed on disk. 

Previous 
Image 

Page_Down When multiple images are loaded, this displays the 
previous sequential image in the image pane 

Next 
Image 

Page_Up When multiple images are loaded, this displays the next 
sequential image in the image pane 

Exit  Ctrl + q Closes the iv application. Note that if you turn off the 
"Ask before closing unsaved images" preference, any 
images will not be saved before closing. If the 
preference is on, you will be prompted to save modified 
images before exiting. 
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Edit Menu 

Control  Hotkey  Functional Description 

Copy Ctrl + c Copies the image to the clipboard. If the Select Tool is 
active, it copies the portion of the image bounded by the 
box to the clipboard 

Paste Ctrl + v Opens a blank image and pastes the contents of the 
clipboard to it 

Clear 
Selection 

  Deletes an existing select box. 

Prioritize 
Selection 

  When selected, this allows you to dynamically select 
buckets for priority rendering. Left clicking on the 
image pane with the shift key down will start rendering 
in a spiral outward from that point. Creating a select 
box (shift-left-drag) will give priority to the buckets 
within the box. 

Crop 
Selection 

  When you are in this mode and you define a new 
selection rectangle, a PYG file is written to 
temp/ivcrop.pyg that contains a single statement which 
sets the crop window used to restrict rendering to a 
subregion of the camera frame. If you input this 
ivcrop.pyg file before your other scene files, then the 
render will automatically be cropped to the selection 
region. You can have this file automatically read in by 
adding it to your $HOME/.gelato.pyg file, or, in 
Mango, setting it as a special input file using the UI 

Preferences   Opens the iv preference window; see below 

View Menu 

Control  Hotkey Functional Description 

Fit Image Home Automatically resizes the image so that the entire 
image is displayed within the current image pane 

Fit Window f Automatically resizes the image pane so that it 
displays the entire image 

Toggle t Switches the current image and the last viewed image 
back and forth in the image pane. 
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Stop Up ] or } Brighten the image by increasing the exposure by one 
point (1/10th of a stop). The Brace '}' will increase 
exposure by a full stop. This is particularly useful 
when viewing floating point image formats with large 
dynamic ranges. 

Stop Down [ or { Darken the image by decreasing the exposure by one 
point (1/10th of a stop). The Brace '{' will decrease 
exposure by a full stop. 

Gamma Up ) Increases the gamma setting of the image in the image 
pane by an increment of 0.1 

Gamma 
Down 

( Decreases the gamma setting of the image in the 
image pane by an increment of 0.1 

Background 
Image 

  Allows you to specify a background image in the 
image pane, visible through transparent elements of 
the current image. Iv will not scale the images to 
match each other. If the images are not of the same 
size, iv will extend the last row and column of the 
background image. For example, if you specify a 
1x1024 vertical ramp image as the background, it will 
be stretched horizontally across the entire image 
background. 

Foreground 
Image 

  Allows you to specify a foreground image in the 
image pane; the current image will be visible only 
through the transparent regions of the foreground 
image. Iv will not scale the images to match each 
other. If the images are not of the same size, iv will 
extend the last row and column of the foreground 
image. 

Surround 
Color 

  Changes the color of the image pane background that 
is visible around the edges of the image. Options are 
black, mid gray, light gray, and white. 

Freeze 
Closeup 
Pixel 

x When the Pixel View Window is open, this holds the 
Pixel View Window centered on the current pixel, 
allowing you to use the mouse for other purposes 

Fullscreen Ctrl + 
Space 

Enlarges the image pane so that fills the entire monitor 
screen; use Ctrl + Space to revert to the previous, 
smaller size 

Random 
Colors 

R Applies a random color map to the pixels; useful when 
contrasting images for minute differences 
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False Color   Applies a "thermal" false coloring color map to the 
image. Most useful when looking at a single channel 
or a grayscale image. Changing exposure up and down 
with the [ and ] hot keys can bring out specific details. 

Subtract s Subtract performs a subtraction between the previous 
and current images. Each pixel in the previous image 
is subtracted from the current one and the absolute 
value is displayed in the window. If difficult to see, 
the difference can be enhanced by adding the random 
color map, hotkey R. This is a useful comparison tool. 

Stereo   Toggles stereo mode. If the previous and current 
images match in size (similar to wiping), this will 
display the previous image in red and overlay the 
current image in blue. This feature is designed to work 
with stereo cameras in gelato, but it will work with 
any two left-right images. 

  Full Color 
c Displays the full-color image (RGBA) 

Red r Displays the red color channel of the image in the 
image pane 

Green g Displays the green color channel of the image in the 
image pane 

Blue b Displays the blue color channel of the image in the 
image pane 

  Alpha a Displays the alpha (opacity) channel of the image in 
the image pane 

Luminance l Displays the brightness of each pixel, calculated from 
the RGB values. 

Previous 
Channel 

, 

(comma)

In single-channel display, decrements the channel 
number being displayed; this is useful in examining 
volume shadow maps and images with more than four 
channels. 

Next 
Channel 

. 

(period) 

In single-channel display, increments the channel 
number being displayed; this is useful in examining 
volume shadow maps and images with more than four 
channels. 

Previous 
Subimage 

< 

(less) 

If the active image has subimages, this moves to the 
previous subimage; this is useful in examining the 
various MIPmap levels in a texture file 
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Next 
Subimage 

> 

(greater) 

If the active image has subimages, this moves to the 
next subimage; this is useful in examining the various 
MIPmap levels in a texture file 

Tools Menu 

Control Hotkey Functional Description 

    Zoom Alt Activates the Zoom Tool and hotkey commands; 
used to zoom in and out on the image; '+' and '-' 
are hotkeys for zoom 

  Select Shift Activates the Select Tool and hotkey commands; 
used to select a portion of the image 

  Pan   Activates the Pan Tool and hotkey commands; 
when not all the image is visible in the image pane 
this is used to re-center the image pane on a 
different portion of the image 

    Wipe Control Activates the Wipe and hotkey commands; when 
multiple images are open this tool allows half the 
image pane to show one image and the other to 
show another; useful when contrasting images 
with minute differences 

Show Pixel View p Opens/Closes the Pixel View Window which 
shows a 9 x 9 grid of individual pixels and X/Y 
coordinate and RGBA color information for the 
center pixel. 

Hide Controls m Hides the Menu and Information Bars. You must 
use the hotkey, m, to bring the controls back. 

Show Error Log e Opens the error log window. The error log 
window can also be opened by clicking on "Error 
Log" in the lower right-hand corner of the iv 
window. 

Annotate   Allows you to add comments to the image that 
appear on the information bar. This is useful for 
distinguishing images that have subtle distinctions. 
The annotation will be saved to certain image 
formats (currently only TIFF). 

Overwrite Render   Checking this box will overwrite the current image 
with the next render. 
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Disconnect Ctrl + d Disconnects iv from the live render. The render 
process will continue writing to a file, but newly 
rendered buckets will no longer be displayed in iv. 
If a live render is not in progress when iv is 
disconnected, the next render will spawn a new 
instance of iv instead of creating a new image in 
the current instance. 

  Kill Render Ctrl + k Kills the render in progress 

  Store Render   Makes a copy of the current image and inserts it 
into the image list, for later viewing; useful for 
saving Gelato renders when Overwrite Render is 
selected. 

Play Forward Right 
Arrow 

In Flipbook Mode, displays the images in order 

Play Reverse Left 
Arrow 

In Flipbook Mode, displays the images in reverse 
order 

Faster Up 
Arrow 

In Flipbook Mode, displays more frames per 
second 

Slower Down 
Arrow 

In Flipbook Mode, displays fewer frames per 
second 

Loop   In Flipbook Mode, displays the sequence in a 
continuous loop, starting again at the beginning 
when the sequence in finished. 

Ping Pong   In Flipbook Mode, displays the sequence of 
images, then the sequence in reverse, and then the 
cycle repeats until stopped. 

Help Menu 

Control Hotkey Functional Description 

iv User's Guide   Displays this iv User's Manual 

About iv   Displays information about the iv program 
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Other Hotkeys 

  Hotkey Functional Description

  Plus (+) Zoom in 

  Minus (-) Zoom out 
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Mouse Buttons 

Mode Left Middle Right Wheel up Wheel down 

    Zoom Zoom in Pan Zoom out     

  Select Select Pan       

  Pan Pan Pan       

    Wipe Wipe Pan       

  

Modifier Left Middle Right Wheel up Wheel down 

Control Wipe     Zoom in Zoom out 

Alt Zoom in   Zoom out     

Shift Select         

The iv Preference Window 
The preference window is opened via the Edit 
menu.This window allows you to alter basic 
iv settings. Changes to these preferences enter 
into effect immediately and are applied to 
future sessions of iv until they are again 
changed. 

Iv currently saves preferences into a file in 
your HOME directory called ".ivrc". You 
must have a HOME environment variable for 
this to work correctly. Under Linux, the 
HOME environment variable is automatically 
defined by the shell, but under Windows, you 
must define this variable manually. 
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Expand window to fit 
new images 

iv will increase the size of the image pane to 
accommodate new images when they are opened. If this 
option is unchecked, only a portion of a large image will 
be visible in the image pane when it is loaded. (You can 
pan to view the portions not displayed.) This option is 
on by default. 

Zoom new image to 
fit window 

iv will increase the size of a new image to fit into the 
existing image pane. If this option is left unchecked, 
small images will be centered in the image pane, 
surrounded by a background color. This option is on by 
default. 

Automatically reload 
partial images 

If you open an image that has only partially completed 
rendering, iv will display the finished portion, and then, 
if this option is enabled, will continue to check the file 
every few seconds to see if new data has been written. If 
so, it loads the new data and updates the view. This 
option is on by default. 

Sort command line 
files 

When this preference is checked, iv will sort input files 
listed on the command line so they come in frame 
number order (e.g., foo.9.tif comes before foo.10.tif). 
Left unchecked, iv will sort them alphabetically by 
filename. This option is particularly useful when loading 
a series of images to play in a flipbook. This option is 
off by default. 

Hide menubar Checking this option will hide the menu and information 
bars. Controls can still be accessed via hotkeys. This 
option is off by default. 

Overwrite render Checking this option will delete the current image from 
iv when a new image is rendered. This saves system 
resources when you are tweaking an scene and do not 
want to compare the previously rendered images with 
the new one. This option is off by default.. 

Ask before closing 
unsaved images 

Checking this option will prompt you to save images 
when you close iv. This option is on by default. 

Full path for file 
name 

Unchecking this option will clip the display of the file's 
path to the number of trailing (parent) directories 
specified. This option is on by default. 

Default gamma Overrides the system environment variable that specifies 
the gamma settings. The default can, in turn, be 
manually changed for each image under the View menu. 
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Look-up table This preference dialog specifies the location of the 
Lookup Table (LUT). The default is 
$GELATOHOME/etc/iv.lut. The LUT allows you to 
make a file containing 256 RGB entries which map 8-bit 
input values from an image to 8-bit output values for 
display on the screen. This is used to mimic the various 
film-response curves for each type of film negative and 
process. To use the LUT, you create a file with 256 
lines, each line containing three numbers between 0-255, 
like this: 

0 0 0 
1 1 1 
2 2 2 
etc. 
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Command Line Options 
When running iv from the command line, you can use the following parameters: 

-help Lists available command line options. 

-gamma <n> 
Sets the default gamma for images. If this parameter is omitted, the 
default for the system (usually 1.0 for Linux and 2.2 for Windows) is 
used. The default can be overridden on a per-image basis. 

-nosort 
Tells iv to load the images in the exact order they are listed on the 
command line. Without this parameter, iv will sort the images to be 
loaded so that frame numbers are sequential, e.g., foo.9.tif, foo.10.tif, 
foo.11.tif. 

-fullscreen Launches iv in fullscreen mode 

-zoom <level> 
Starts iv at a particular level of zoom, ranging from -4 to 4. If this 
parameter is not given, iv launches at level 0. Each level doubles in 
scale, so 1 is double-sized, 2 is quadrupled, -1 is half size, etc. 

-expand 

Causes iv to automatically expand its size when an image is loaded or 
switched to, if that image is larger than the current window size. By 
default, this feature is off, meaning that the window size will remain 
the size of the first image loaded during the iv session, unless the user 
takes an action to resize the window. 

-play <n> 
Starts iv in flipbook mode at the specified frames per second. Note 
that n is a floating point number, and may be less than 1 (e.g., -play 
0.1 will display frames for 10 seconds each). 

-loop <n> Used in conjunction with the -play n parameter, this instructs iv to 
play the flipbook n times and then exit. 

-F 
Runs iv in the foreground instead of automatically forking and killing 
the parent process. By default, iv will run in the background so that 
you can view the file and continue to use the shell. This parameter is 
used primarily for debugging and in normal usage will not be needed. 

-verbosity <n> 

Controls the amount of message traffic generated by a Gelato render. 
n can be assigned one of three values. 0 reports errors only. 1 (the 
default) also prints warnings. 2 provides additional debugging 
information; used primarily for debugging image I/O plug-ins, where 
you want to set verbosity to 2 

-debugdso 
Outputs information about all DSO/DLL loads, useful in debugging 
why image I/O plug-ins are not being found; used primarily for 
debugging image I/O plug-ins 
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Configuration 

Configuration File 

iv reads a configuration file stored in $HOME/.ivrc on startup. The file syntax is to 
have a single assignment statement on each line.  Blank lines are fine, and comment lines 
begin with a hash mark. This file can contain any of the following user preferences: 

gamma = %f 
The default gamma value used for all image types unless 
otherwise specified on the command line or with one of the 
image-specific gammasettings.  

gamma.extension=%f 
Type-specific gamma value.  For example, you can set the 
gamma used just for TIFF files using: 
    gamma.tif=2.2 

save_image_filename=%s 
This preference allows you to change the filename used to 
save images with Ctrl-s from the default value of  
"/tmp/iv.tif". 

save_window_filename=%s 
This preference allows you to change the filename used to 
save the current window view with Shift-Ctrl-s from 
the default value of  "/tmp/ivfb.tif". 

background=%f Set the default background gray value used whenever the 
current image is smaller than the active window. 

sort=%d 
A zero value will disable the image filename sorting done 
by default at startup.  Setting this to zero is the same as 
using the -nosort command line option. 

autozoom=%d 
A value of zero will disable the autozoom feature which 
scales down images that are too large to fit on the screen at 
startup. 

fullscreen=%d 
A nonzero value will force \ivbinary to startup in fullscreen 
mode, as if -fullscreen was passed on the command 
line. 

expand_to_fit=%d 

A nonzero value will cause the display window to resize 
when larger images are displayed if the window is not 
already large enough,as if  -expand was passed on the 
command line. 

MainWindow.x=%d 
MainWindow.y=%d 

Set the default startup position of the display window 
(default is 0,0). 
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Here is an example configuration file: 

# Example configuration file for iv 
 
# You can set a different gamma value for each image type 
# using the syntax "gamma.<extension>".  Images sent from 
# gelato currently do not have an associated image type, 
# and instead use the global gamma setting which come  
# from the "gamma" value below, or the command line 
gamma = 2.2 
gamma.jpg = 1.0 
gamma.tif = 2.2 
 
# Set the name of the save and savewindow filenames 
save_image_filename = /home/dwexler/iv.tif 
save_window_filename = /home/dwexler/ivfb.jpg 
 
# You can change your background color with this: 
background = 0.5 
 
# This disables sorting of input images if set to zero 
#sort = 1 
 
# This disables the autozooming of large images if 
# set to zero 
autozoom = 1 

Environment Variables 

iv's behavior is influenced by the following environment variables of the command 
shell: 
 
GAMMA Gives the default gamma correction to use when displaying files (default 

is 1.0).  This may be overridden by the configuration file or the command-
line -gamma option. 

 
As a reminder, below we show how to set the GAMMA environment variable to 2.2 using a 
variety of shells: 
 
csh, tcsh:                setenv GAMMA 2.2 
 
ksh, bash:               export GAMMA=2.2 
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Tips 
•  iv can read TIFF images that gelato is still in the middle of rendering, though 

it will only display the portion that has thus far been saved to the image file.  But 
hitting ENTER periodically will make iv reread the file and display the newly 
rendered portion. 

•  Except when using the -nosort option, iv is smart about typical ways of 
naming consecutive frames of an animation.  Images numbered like 
this f.8.tif, f.9.tif, f.10.tif will load in the proper order into iv for 
flipbook playback, even though standard alphanumeric sorting would put them in 
the wrong order.  So, if you have all your frames in a single directory, you can use 
\ivbinary as a flipbook with the command 
 
      iv -fps 24 * 

•  iv can be used to display a "slide show'' for still images by giving it a sequence 
of images and telling it a very low frames per second.  For example, 
 
        iv -fullscreen -play 0.1 -loop 2 slide*.tif 
 
will loop through all the TIFF files twice, displaying each image full screen for 10 
seconds. 

•  Use copy and paste between separate \ivbinary windows to compare 
nonconsecutive renders.  After pasting, try toggling ('t') or wiping ('Control+Left') 
between the two images to look for differences. Setting random colors ('x') will 
make the image confusing, but makes it easy to see even single pixel differences. 

•  iv will display error messages in the top left portion of the window.  These 
messages remain for a specified minimum period of time and then disappear the 
next time the image is repainted. 

•  When creating a demo, try using the -fullscreen and -zoom options for the 
\ivbinary output imageio DSO. 
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